Website Outage

Incident Report for Swyft

Resolved

The DNS issues with our provider have been fully resolved. Since no changes were made on our end, your connection should be restored immediately. Rest assured, all Velocty dashboards and features remained unaffected, as they are hosted on secure, private servers exclusively managed by Swyft.
Posted Mar 28, 2025 - 19:18 GMT-01:00

Identified

All websites under the swyft.live TLD are currently down due to a DNS issue. We are actively working with our DNS provider to resolve the problem as quickly as possible. We apologize for any inconvenience and appreciate your patience.
Posted Mar 28, 2025 - 19:13 GMT-01:00
This incident affected: Client Portal Access and Help & Support Center.